またも画像がみられません 
haji LAGUNA @東京都 9/10(土) 14:06:34 No.20050910140634
しばらく前にあったのと同じ症状が出ています。
どうもメガニストのトップページが何らかの悪さをしているようなのですが。
(トップページを踏むとその後はどのサイトを見ても画像がでなくなります)
いったいなんなんでしょうか???

1.  estac MEGANE(HATCH) @宮城県    9/10(土) 16:08:58 No.20050910140634-1
hajiさん,ほかのみなさん,ご迷惑をおかけしています。

いろいろネットで情報を収集しているところなのですが,
いかんせんスタッフ6人のだれも同じ症状が出ていないもので
対処に苦慮しているのが実情です。

文法等の再チェックはかけているのですが・・・
何か秘孔を突く記述をしているのかもしれません。

ある日突然に発症していることを考えると
(前回はある日突然自然治癒)
IEやセキュリティソフトのアップデートが原因なのかなと思ったり・・・。

なお,ブラウザは個人の選択の自由ではありますが
あまりにご不便でしたらIE以外のブラウザを試用してみてください。

ご不便をおかけしています。I


2.  Nojee MEGANE(HATCH) @静岡県    9/10(土) 16:29:55 No.20050910140634-2
ご迷惑をおかけしてます。

僕も自分のサイトで、MacOS9 IE5.2(5.5だったかな?)で
ほんの1行の記述が処理できなくて、フリーズしてしまったことがあります。

根本的な解決になりませんが、ブラウザーのFireFoxを使ってみてください。
メガニストのサイトがちゃんと表示されるだけではなく、
他のサイトも、パソコンが新しくなったような錯覚を覚えるくらい早く表示されます。

Firefox - Web の再発見
http://www.mozilla-japan.org/products/firefox/


3.  estac MEGANE(HATCH) @宮城県    9/10(土) 19:52:13 No.20050910140634-3
トップページにテスト画像のみを並べてある状態にしましたが

この場合,表示の具合はいかがですか?


4.  maruu MEGANE(HATCH) @東京都    9/11(日) 08:40:55 No.20050910140634-4
estacさん、OKです。テスト画像鮮明です。その他の画像も「ほとんど」は回復しました。ありがとうございます。
一部のブログに、「文字化け? 画像無し?」があります。

P.S. Nojeeさんご推奨の Firefox 使用してみました。


5.  maruu MEGANE(HATCH) @東京都    9/11(日) 09:17:48 No.20050910140634-5
blogの、×=文字化け、画像無し、△=文字化け、画像有り、○=正常、のほんの一例(新着順の一部のみの例)を挙げます。
×:「daily affairs」「I家の日々」「Life with 2 and 4 wheels」「Slowでいいでしょ」・・・・・・
△:「clear Blue」・・・・・・
○:「Drop the Beat」「Influencia do Jazz」「コロンビー/Authentic=ホンモノ?」・・・・・


6.  estac MEGANE(HATCH) @宮城県    9/11(日) 10:08:33 No.20050910140634-6
原因がわかってきました。

Photo in BBS にて,ある特定の情報が付随したjpg画像を表示してしまうと,IEで一連の症状が出るようです。

平たく言うとIEのバグ?のようです。

現在,対策を検討中ですが,最新バージョンのIEでは発症しないようですから,できるだけIEのアップデートをしていただけると幸いです。

maruuさんの文字化け等の症状はまた別の原因と思われますが,
IEのメニューから
  表示(v)→エンコード→自動選択
として解決しないでしょうか?


7.  maruu MEGANE(HATCH) @東京都    9/11(日) 18:00:34 No.20050910140634-7
はい、そのとおり、表示(v)→エンコード→自動選択 で解決しました。すぐ、直るのですね。


8.  estac MEGANE(HATCH) @宮城県    9/13(火) 01:59:58 No.20050910140634-8
さて,抜本的対策をmiyaさんにしていただきました。

maruuさん,sadaさん,hajiさん,異常はないでしょうか・・・?


9.  estac MEGANE(HATCH) @宮城県    9/13(火) 02:15:47 No.20050910140634-9
と思ったらまだのようです。今しばらくお待ちください。


10.  haji LAGUNA     9/13(火) 21:10:47 No.20050910140634-10
現時点では改善の兆しは見られません。

これは少々言いにくいことなのですが、メガニストBBSに画像が貼られるとバグが起こるというところまで分かっているのでしたら、当面、画像の張付けを出来なくするのが最短の解決法ではないでしょうか。
ユーザーに他所のブラウザを勧めるのはその後ではないかと思います。


11.  estac MEGANE(HATCH) @宮城県    9/13(火) 22:00:19 No.20050910140634-11
hajiさん,こんばんは。

言葉を選んだつもりでしたが,不快感をお感じになったとしたら申し訳ありませんでした。

表示が異常になる原因がわかりましたので,私たちは以下の対策を講じました。

☆原因
投稿されるjpg画像にはexifという付帯情報が含まれている場合があります。これはデジカメや画像処理ソフトが自動的に付けてしまうものです。投稿する方にとって,その有無・内容は通常意識されないものです。この付帯情報内に,「ある特定の文字列(表記)」があると,最新バージョンでないインターネットエクスプローラはくだんの異常を起こしてしまいます。

☆対策
投稿画像を受け付ける際にプログラムで自動的にこの不要な付帯情報を除去するよう対策しました。実装済みです。

☆問題点
新たに受け付ける投稿画像は上記の対策で処理できるのですが,過去の画像は処理できません。ひとつひとつチェックして手作業で処理する必要があります。

今日hajiさんがご覧になった時に改善していなかったのは,その異常を引き起こした過去の投稿画像がまだトップページに存在したからです。それには昨夜気付いたのですがタイムスタンプをご覧になってわかるように深夜でしたのであきらめました。実世界では普通のサラリーマンなものですから・・・。

さきほど私が害のない画像を投稿したので現在は正常かと思います。
いかがでしょうか・・・。

ご迷惑をおかけしました。
上記の対策を講じましたので,画像投稿をできなくすることはいたしません。みなさん,どしどし投稿してください。

長文失礼いたしました。


12.  haji LAGUNA @東京都    9/13(火) 23:33:27 No.20050910140634-12
すばやい対応ありがとうございます。
おかげで問題なく見られるようになりました。

私もPCは得意なほうですが、exifなるものは初めて聞きました。
投稿者も受けるほうも知らない内に組み込まれている…。ある日突然トラブルを起こすが、熟練者以外には原因がつかめない。なんか怖いですね。


13.  miya MEGANE(CC) @宮城県    9/13(火) 23:38:11 No.20050910140634-13
えーっと、現在、トップページから写真を除いています。

根本原因は、IEのバグです。
(最新版では直っているという話のようですが、スタッフ(複数)の環境では発生しないので良く分からないのが実状です)

estacさんが書かれた対処は、実装しましたが、まだいくつか問題があり、バグ回避には至っていません。スミマセン。


14.  風の谷 MEGANE(HATCH) @大阪府    9/14(水) 07:02:28 No.20050910140634-14
hajiさん、「exif」というのは怪しげな物じゃなくって、撮影時の時間や撮影条件(シャッタースピードや絞り)等のその写真に関する付加情報です。jpegには映像だけじゃなく、その映像に関する付加情報を保持する機能が用意されてるんです。

写真の加工ツールによっては、加工後のjpegファイルからはexifを取り除くように設定できるかと思いますよ。


15.  sada MEGANE(HATCH) @埼玉県    9/14(水) 09:22:35 No.20050910140634-15
研修等でしばらくオフィスを留守にしていました。久しぶりに出社しPCを開いて見ましたが、問題は解消しているようです。
MEGANISTEのページも問題ありませんし、そこから他のHPに飛んでも問題ありません。
ご対応頂き、有難う御座いました。


返信投稿

なまえ
メールアドレス
本文  アドレスをリンクする  〔 画像の添付と削除
パスワード     なまえ等を保存

掲示板に戻る      ホームページに戻る